Jump to content
GARLIN

Pest or deficiency?

Recommended Posts

Hi All,

 

This my first grow and sort of found my through it by reading online and asking questions. I've recently experienced that my plants leaves are getting spots then turning yellow and eventually just falling off. Look at the pic and advise if anyone can. Is it a pest or calcium deficiency ?

 

 

WhatsApp Image 2019-05-29 at 08.24.51.jpeg

  • Like 1

Share this post


Link to post
Share on other sites

Hey bro 

Any other info on the grow ? Looks like a deficiency for sure 

Share this post


Link to post
Share on other sites

Its close to switching over to flower and have noticed this since Sunday. The plants are all growing in soil , organic promix , I make sure the ph of my water is right all the time. Plants are under 2 x 300w cfl dual spectrum lights which i bought from futurama .

I monitor the environment as well. Its been a bit cold these last few days so I added a 300 hps light just get the temp up in the room...

Thats about it 

 

Share this post


Link to post
Share on other sites

IMO id say it needs some cal mag and maybe some N like @greenkush  was saying 

As you go into flower though you going to want to lower the N and increase P and K 

  • Agree 1

Share this post


Link to post
Share on other sites

Spotting and yellow leaves could be magnesium def, especially of you finding it on the lower leaves. It's a mobile nutrient, so the new growth pulls it up from the older leaves if it's lacking or locked out in the medium. Reset with a flush and take it from there.

  • Like 1
  • Agree 1

Share this post


Link to post
Share on other sites

What brand of soil? Promix sounds like a Coco coir based mix

 

Sent from my VTR-L09 using Tapatalk

 

 

 

 

Share this post


Link to post
Share on other sites
This is an hydroponic based grow medium. It contains about enough nutrients for 2-6 weeks depending on the size of the plant. It says organic because it is amended with some organic Nutrients. But it is not. You will have to feed salts.

Sent from my VTR-L09 using Tapatalk

Share this post


Link to post
Share on other sites
Posted (edited)

I personally dont think that is a deficiency but like @CG420za said a flush would be your best place to start.  Looks like burn or root damage  to me ....just my 2 cents 

Edited by Green Leaf Organics

Share this post


Link to post
Share on other sites

For me it looks like nutrient lockout due to pH imbalance.

Sent from my VTR-L09 using Tapatalk

Share this post


Link to post
Share on other sites

@GARLIN has this literally crept up in a few days. How long have these signs been showing?

Share this post


Link to post
Share on other sites

yes it has the 5 to 6 days at most I would say .... Im not in there daily because of my work schedule so I cant exactly say

Share this post


Link to post
Share on other sites
1 minute ago, SkunkPharm said:

For me it looks like nutrient lockout due to pH imbalance.

That's what it looks like to me. What are you feeding it and with what PH?

Share this post


Link to post
Share on other sites
3 minutes ago, SkunkPharm said:

For me it looks like nutrient lockout due to pH imbalance.

Sent from my VTR-L09 using Tapatalk
 

More than likely right on this one , just read the medium he was using 

  • Like 2
  • Agree 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...