Jump to content
Shaun

Help please

Recommended Posts

Hi guys met another grower today he is also new to growing but a bit further along than I am he is just going into flower but his plants not looking healthy 

It's a closet grow he says he has not watered it in 3 days so I'm hoping it's just a watering issue he also just using tap water and does not even check the ph 

Any advice would really be appreciated 

20190612_184117.jpg

20190612_184104.jpg

Share this post


Link to post
Share on other sites

Its living soil but all good I watered them and they have bounced back within an hour 

IMG-20190613-WA0001.jpg

  • Like 2

Share this post


Link to post
Share on other sites

Thanks dude that's exactly what it was just watered them and all sorted thanks for the input 

Share this post


Link to post
Share on other sites

Hey guys I'll upload some pics the new auto are doing well two a bit behind the other two o think I was overwatering I watered and the run off was really smelly so I transplanted I know it's not good to do for auto but felt I had to do something but my bigger plants seem to be very light green colour anyone know why this is all I have managed to source is it might be calcium deficiency 

 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...