Jump to content
My BIKE

Help, need diagnosis on leaf appearance

Recommended Posts

Hi,

Can anyone please help me, I don't know if this is a fungi/disease or a nutrient deficiency. I have good ventilation, humidity is almost constant at 65% and temperature never go below 20 Celsius and never go higher than 29 Celsius.      I give them special cannabis feed (bio-grow) powder. PH is 6,7 (soil). I have four plants which two are effected and the other two is doing perfectly fine and they all get the same nutrients and have the same soil mixture.

Your help is appreciated.    

IMG-20190414-WA0012.jpg

IMG-20190414-WA0011.jpg

IMG-20190414-WA0010.jpg

IMG-20190414-WA0015.jpg

IMG-20190414-WA0016.jpg

IMG-20190414-WA0013.jpg

IMG-20190414-WA0014.jpg

Share this post


Link to post
Share on other sites

What soil are you using? It looks like a pH issue. Nutrient lock out. If it is soil why are you feeding nutrient at this early stage?

Sent from my VTR-L09 using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...